idk, I really feel like I should write a blog post, or docs, or something about this. `static mut` is really footgunny (more so than UnsafeCell IMO), but this is one of those things that: * IS decently challenging to get right * WAS often incorrect many times * Many people THINK they know how it does/should work I think the change to UnsafeCell is better, it closes a couple doors like "`static mut` makes everything `Sync`", where for different types you can do stuff like `unsafe impl Sync for Container {}`, or `unsafe impl Sync for Container {}` or so.